Pages

07/06/2021

Return of the Cisco 887VA - Testing and updated config

 Around 3 years ago I blogged about using a Cisco 887VA Router as a VDSL Modem.  As far as I recall I actually documented the configuration whilst getting ready to sell it, as I was downsizing my network.

Well, my network has since creeped back up in both size and complexity so I wanted to swap out the venerable Huawei HG612 VDSL modem for something else that could be rack mounted (cos bling). A quick google suggested the Cisco 887VA was still a good way to go, so I purchased another.



This time around I was a little more concerned it wouldn't be able to handle the throughput of my VDSL connection (50 Mb/s Down, and 16 Up). I think previously when  swapped the previous modem for the 887, I ran a test on speedtest.net, and called it good when it showed a similar result to the Huawei.

I've since come to realise theres a bit more to it than that, with things like packet size and UDP vs TCP having quite a large impact on a devices maximum throughput, so I thought I should test the 887 more thoroughly before making it permanent. 

Throughput Testing

To test the throughput I used Mikrotik's Bandwidth Test which is built into their routers. For the remote side I spun up a cheap VPS and installed Mikrotiks "Cloud" router. Unfortunatly I don't have the facility to emulate a full speed (80/20 Mb/s) VDSL connection so I had to use my own 50/16 link. It's not quite a fair test as both local utilisation and congestion within my ISPs network might impact the results, but it should give a ball park indication that the 887 can cope with the throughput. 

I compared the Cisco 887VA with the original Huawei HG612 and a ZyXEL VMG1312-T20B.

Here's the results. All speeds are measured in MB/s:
DownloadUploadBoth
ProtocolUDPTCPUDPTCPUDPTCP
Packet Size150051264150015005126415001500512641500
Huawei55.453.131.853.417.116.612.216.4Rx: 55.4
Tx: 17
Rx: 53.2
Tx: 5.7
Rx:
Tx:
Rx: 52.7
Tx: 15.2
Zyxel5351.335.551.618.71812.517.7Rx: 53.5
Tx: 18.8
Rx: 51.1
Tx: 18
Rx: 31
Tx: 12.5
Rx: 50.8
Tx: 16.2
Cisco (No ACL)5653.737.453.718.417.61217.7Rx: 56
Tx: 18.4
Rx: 53.8
Tx: 17.6
Rx: 28
Tx: 10.2
Rx: 51.4
Tx: 16.1
Cisco (ACL)5653.737.453.818.417.61217.7Rx: 56
Tx: 18.4
Rx: 53.7
Tx: 17.6
Rx: 27
Tx: 10.3
Rx: 50
Tx: 16.2
Red indicates a failed test, either the modem locked up, or I was unable to get a reliable reading.

As you can see, the Cisco outperformed the Huawei in every test. The Zyxel was a little faster on the Upload side but that might have been down to the line rate at the time of the test - the difference certainly isn't large enough to be concerning.

Furthermore when running a full speed bi-directional TCP test, the CPU on the Cisco 887VA was around 20%, suggesting suitable headroom to support a full speed 80/20 VDSL connection but YMMV.

Power Testing

Another thing I hadn't previously tested was power usage. Some Cisco gear can be incredibly power hungry (100W+ ) which isn't ideal, so I wanted to check the power consumption.

I plugged it into a tasmota'd socket which indicated the consumption was around 11 Watts which is fairly palatable. 

Configuration

The 887VA I received was on a newer IOS version than my previous one (15.3 vs 15.1) so the previous config didn't work properly.

Below is the revised and slightly simplified configuration. As before I'm not a Cisco expert and this configuration is fairly niche, so I can't make any guarantees it's the most efficient or secure setup, but I'm happy with it.

It's configured to support Baby Jumbos allowing a full 1500 byte packet to pass over the PPPoE connection, and also setup to use VLAN 101 on the VDSL side -  a common requirement for most (all?) UK providers.

The router is assigned the IP 192.168.15.1/30 for management, with the expectation that a downstream router will be on 192.168.15.2/30 and any connections are NATed from this IP. You could add static routes instead if you wish.

You can plug the downstream router into any of the 4 FastEthernet ports on the front of the 887.

The config:
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service password-recovery
!
hostname MODEM-01.WD18-01
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
enable secret 9 PASSWORD
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
ip domain name lan.marrold.co.uk
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
license udi pid C887VA-K9 sn FCZ1941950P
license boot module c800 level advipservices
!
!
vtp mode transparent
username admin privilege 15 secret 9 PASSWORD
!
!
!
!
!
controller VDSL 0
 operating mode vdsl2
 modem 0
 modem ukfeature
!
vlan 100-101
!
ip ssh version 2
ip scp server enable
!
!
!
!
!
bridge irb
!
!
!
!
!
interface ATM0
 no ip address
 no ip route-cache
 shutdown
 no atm ilmi-keepalive
!
interface Ethernet0
 mtu 1508
 no ip address
 no ip route-cache
!
interface Ethernet0.100
 no ip route-cache
!
interface Ethernet0.101
 encapsulation dot1Q 101
 ip virtual-reassembly in
 no ip route-cache
 bridge-group 1
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface Vlan1
 mtu 1508
 no ip address
 ip virtual-reassembly in
 bridge-group 1
!
interface BVI1
 mtu 1508
 ip address 192.168.15.1 255.255.255.252
 ip virtual-reassembly in
!
ip default-gateway 192.168.15.2
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 BVI1 192.168.15.2
!
!
access-list 10 permit 192.168.15.0 0.0.0.3
access-list 10 deny   any
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
line con 0
 no modem enable
line aux 0
line vty 0 4
 logging synchronous
 login local
 transport preferred none
 transport input ssh
!
scheduler allocate 20000 1000
!
end

Conclusion

So to conclude, I think the Cisco 887VA is a suitable replacement for the Huawei HG612 modem and doesn't introduce a new bottle neck on my ~50/16 VDSL line, and whilst untested I think it would perform adequately on a full speed 80/20 line.

Should you rush out and buy one? Probably not, I mostly got one for the aesthetic of rack mount gear. One benefit of the Cisco is some more detailed line stats, shown below. 

MODEM-01.WD18-01#show controllers VDSL 0
Controller VDSL 0 is UP

Daemon Status:		 Up

			XTU-R (DS)		XTU-C (US)
Chip Vendor ID:		'BDCM'			 'BDCM'
Chip Vendor Specific:   0x0000			 0xC190
Chip Vendor Country:    0xB500			 0xB500
Modem Vendor ID:	'CSCO'			 '    '
Modem Vendor Specific:  0x4602			 0x0000
Modem Vendor Country:   0xB500			 0x0000
Serial Number Near:    FCZ1941950P C887VA-K 15.3(3)M6
Serial Number Far:     Q10H7000598_39
Modem Version Near:    15.3(3)M6
Modem Version Far:     0xc190

Modem Status:		 TC Sync (Showtime!)
DSL Config Mode:	 VDSL2
Trained Mode:		 G.993.2 (VDSL2) Profile 17a
TC Mode:		 PTM
Selftest Result:	 0x00
DELT configuration:	 disabled
DELT state:		 not running
Trellis:		 ON			  ON
SRA: 			 disabled			 disabled
 SRA count: 		 0			 0
Bit swap: 		 enabled			 enabled
 Bit swap count:	 0			 0
Line Attenuation:	  0.0 dB		  0.0 dB
Signal Attenuation:	  0.0 dB		  0.0 dB
Noise Margin:		  4.6 dB		  6.0 dB
Attainable Rate:	51916 kbits/s		 19204 kbits/s
Actual Power:		 12.5 dBm		  7.6 dBm
Per Band Status:       	D1 	D2 	D3 	U0 	U1 	U2 	U3
Line Attenuation(dB):   12.8	31.8	52.3	4.8	23.9	38.4	N/A
Signal Attenuation(dB): 12.8	31.8	52.3	4.8	23.0	37.4	N/A
Noise Margin(dB):       4.6	4.5	4.5	6.0	6.0	6.0	N/A
Total FECC:		5208174			 1991
Total ES:		147			 300
Total SES:		95			 0
Total LOSS:		3			 0
Total UAS:		2498			 2498
Total LPRS:		0			 0
Total LOFS:		3			 0
Total LOLS:		0			 0

Full inits:		2
Failed full inits:	0
Short inits:		0
Failed short inits:	1

Firmware	Source		File Name (version)
--------	------		-------------------
VDSL		embedded   	VDSL_LINUX_DEV_01212008 (1)

Modem FW  Version:	130205_1433-4.02L.03.A2pv6C035j.d23j
Modem PHY Version:	A2pv6C035j.d23j
Vendor Version:		Ap6v35j.23j 68


 		  DS Channel1	  DS Channel0	US Channel1	  US Channel0
Speed (kbps):	          0	       58563	         0	       19204
SRA Previous Speed:       0	       58326	         0	       19201
Previous Speed:	          0	       58326	         0	       19201
Reed-Solomon EC:       1189	      509842	         0	         322
CRC Errors:	       3838	        3838	       378	         378
Header Errors:	          0	           0	         0	           0
Interleave (ms):       0.00	        0.00	      0.00	        0.00
Actual INP:	       2.00	       49.00	      0.00	        0.00

Training Log :	Stopped
Training Log Filename :	flash:vdsllog.bin

No comments:

Post a Comment